about summary refs log tree commit diff
path: root/third_party/lisp/global-vars.nix
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/lisp/global-vars.nix')
-rw-r--r--third_party/lisp/global-vars.nix14
1 files changed, 14 insertions, 0 deletions
diff --git a/third_party/lisp/global-vars.nix b/third_party/lisp/global-vars.nix
new file mode 100644
index 0000000000..2b4078f588
--- /dev/null
+++ b/third_party/lisp/global-vars.nix
@@ -0,0 +1,14 @@
+{ depot, pkgs, ... }:
+
+let
+  src = pkgs.fetchFromGitHub {
+    owner = "lmj";
+    repo = "global-vars";
+    rev = "c749f32c9b606a1457daa47d59630708ac0c266e";
+    sha256 = "06m3xc8l3pgsapl8fvsi9wf6y46zs75cp9zn7zh6dc65v4s5wz3d";
+  };
+
+in depot.nix.buildLisp.library {
+  name = "global-vars";
+  srcs = [ "${src}/global-vars.lisp" ] ;
+}