about summary refs log tree commit diff
path: root/third_party/lisp/drakma.nix
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/lisp/drakma.nix')
-rw-r--r--third_party/lisp/drakma.nix6
1 files changed, 4 insertions, 2 deletions
diff --git a/third_party/lisp/drakma.nix b/third_party/lisp/drakma.nix
index ac2d257a49..aac85909d1 100644
--- a/third_party/lisp/drakma.nix
+++ b/third_party/lisp/drakma.nix
@@ -1,16 +1,17 @@
 # Drakma is an HTTP client for Common Lisp.
 { pkgs, ... }:
 
+with pkgs.nix;
+
 let src = pkgs.third_party.fetchFromGitHub {
   owner = "edicl";
   repo = "drakma";
   rev = "87feb02bef00b11a753d5fb21a5fec526b0d0bbb";
   sha256 = "01b80am2vrw94xmdj7f21qm7p5ys08mmpzv4nc4icql81hqr1w2m";
 };
-in pkgs.nix.buildLisp.library {
+in buildLisp.library {
   name = "drakma";
   deps = with pkgs.third_party.lisp; [
-    asdf
     chipz
     chunga
     cl-base64
@@ -19,6 +20,7 @@ in pkgs.nix.buildLisp.library {
     flexi-streams
     puri
     usocket
+    (buildLisp.bundled "asdf")
   ];
 
   srcs = map (f: src + ("/" + f)) [