about summary refs log tree commit diff
path: root/third_party/lisp/defclass-std.nix
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/lisp/defclass-std.nix')
-rw-r--r--third_party/lisp/defclass-std.nix19
1 files changed, 19 insertions, 0 deletions
diff --git a/third_party/lisp/defclass-std.nix b/third_party/lisp/defclass-std.nix
new file mode 100644
index 0000000000..2573e46f53
--- /dev/null
+++ b/third_party/lisp/defclass-std.nix
@@ -0,0 +1,19 @@
+{ depot, pkgs, ... }:
+
+let src = pkgs.fetchFromGitHub {
+    owner = "EuAndreh";
+    repo = "defclass-std";
+    rev = "0300f171c1308e5ff3efd66b4f4e766f2bcde259";
+    sha256 = "0ggzh80ajx4k6w5c3xprnd7m27q5hx9xx9lxs4jv0pbrlg18ijcw";
+  };
+in depot.nix.buildLisp.library {
+  name = "defclass-std";
+  deps = with depot.third_party.lisp; [
+    alexandria
+    anaphora
+  ];
+
+  srcs = map (f: src + ("/src/" + f)) [
+    "defclass-std.lisp"
+  ];
+}