about summary refs log tree commit diff
path: root/third_party/lisp/defclass-std.nix
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/lisp/defclass-std.nix')
-rw-r--r--third_party/lisp/defclass-std.nix9
1 files changed, 3 insertions, 6 deletions
diff --git a/third_party/lisp/defclass-std.nix b/third_party/lisp/defclass-std.nix
index 2573e46f53..c31ddb3c5b 100644
--- a/third_party/lisp/defclass-std.nix
+++ b/third_party/lisp/defclass-std.nix
@@ -1,11 +1,8 @@
+# A shortcut macro to write DEFCLASS forms quickly
+# Seems to be unmaintained (since early 2021)
 { depot, pkgs, ... }:
 
-let src = pkgs.fetchFromGitHub {
-    owner = "EuAndreh";
-    repo = "defclass-std";
-    rev = "0300f171c1308e5ff3efd66b4f4e766f2bcde259";
-    sha256 = "0ggzh80ajx4k6w5c3xprnd7m27q5hx9xx9lxs4jv0pbrlg18ijcw";
-  };
+let src = with pkgs; srcOnly lispPackages.defclass-std;
 in depot.nix.buildLisp.library {
   name = "defclass-std";
   deps = with depot.third_party.lisp; [