about summary refs log tree commit diff
path: root/third_party/lisp/closer-mop.nix
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/lisp/closer-mop.nix')
-rw-r--r--third_party/lisp/closer-mop.nix15
1 files changed, 7 insertions, 8 deletions
diff --git a/third_party/lisp/closer-mop.nix b/third_party/lisp/closer-mop.nix
index ab7e33e59b..145b9cfd43 100644
--- a/third_party/lisp/closer-mop.nix
+++ b/third_party/lisp/closer-mop.nix
@@ -1,20 +1,19 @@
 # Closer to MOP is a compatibility layer that rectifies many of the
 # absent or incorrect CLOS MOP features across a broad range of Common
 # Lisp implementations
-{ depot, ... }:
+{ depot, pkgs, ... }:
 
-let src = depot.third_party.fetchFromGitHub {
-  owner = "pcostanza";
-  repo = "closer-mop";
-  rev = "e1d1430524086709a7ea8e0eede6849aa29d6276";
-  sha256 = "1zda6927379pmrsxpg29jnj6azjpa2pms9h7n1iwhy6q9d3w06rf";
-};
+let src = with pkgs; srcOnly lispPackages.closer-mop;
 in depot.nix.buildLisp.library {
   name = "closer-mop";
 
   srcs = [
     "${src}/closer-mop-packages.lisp"
     "${src}/closer-mop-shared.lisp"
-    "${src}/closer-sbcl.lisp"
+    {
+      sbcl = "${src}/closer-sbcl.lisp";
+      ecl = "${src}/closer-ecl.lisp";
+      ccl = "${src}/closer-clozure.lisp";
+    }
   ];
 }