about summary refs log tree commit diff
path: root/third_party/lisp/cl-yacc.nix
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/lisp/cl-yacc.nix')
-rw-r--r--third_party/lisp/cl-yacc.nix15
1 files changed, 15 insertions, 0 deletions
diff --git a/third_party/lisp/cl-yacc.nix b/third_party/lisp/cl-yacc.nix
new file mode 100644
index 0000000000..d2ceb81103
--- /dev/null
+++ b/third_party/lisp/cl-yacc.nix
@@ -0,0 +1,15 @@
+{ depot, pkgs, ... }:
+
+let src = pkgs.fetchFromGitHub {
+    owner = "jech";
+    repo = "cl-yacc";
+    rev = "1334f5469251ffb3f8738a682dc8ee646cb26635";
+    sha256 = "16946pzf8vvadnyfayvj8rbh4zjzw90h0azz2qk1mxrvhh5wklib";
+  };
+in depot.nix.buildLisp.library {
+  name = "cl-yacc";
+
+  srcs = map (f: src + ("/" + f)) [
+    "yacc.lisp"
+  ];
+}