about summary refs log tree commit diff
path: root/third_party/lisp/checkl.nix
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/lisp/checkl.nix')
-rw-r--r--third_party/lisp/checkl.nix26
1 files changed, 0 insertions, 26 deletions
diff --git a/third_party/lisp/checkl.nix b/third_party/lisp/checkl.nix
deleted file mode 100644
index 33c2330ecf..0000000000
--- a/third_party/lisp/checkl.nix
+++ /dev/null
@@ -1,26 +0,0 @@
-{ depot, pkgs, ... }:
-
-let
-  inherit (depot.nix.buildLisp) bundled;
-
-  src = pkgs.fetchFromGitHub {
-    owner = "rpav";
-    repo = "CheckL";
-    rev = "80328800d047fef9b6e32dfe6bdc98396aee3cc9";
-    sha256 = "0bpisihx1gay44xmyr1dmhlwh00j0zzi04rp9fy35i95l2r4xdlx";
-  };
-
-in depot.nix.buildLisp.library {
-  name = "checkl";
-  deps = with pkgs.lisp; [
-    (bundled "asdf")
-    marshal
-    fiveam
-  ];
-
-  srcs = map (f: src + ("/" + f)) [
-    "package.lisp"
-    "checkl.lisp"
-    "formalize.lisp"
-  ];
-}