about summary refs log tree commit diff
path: root/third_party/lisp/asdf.nix
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/lisp/asdf.nix')
-rw-r--r--third_party/lisp/asdf.nix9
1 files changed, 9 insertions, 0 deletions
diff --git a/third_party/lisp/asdf.nix b/third_party/lisp/asdf.nix
new file mode 100644
index 0000000000..3d41a1f36d
--- /dev/null
+++ b/third_party/lisp/asdf.nix
@@ -0,0 +1,9 @@
+# ASDF ships with SBCL. This package just exists to force it to load.
+{ pkgs, ... }:
+
+with pkgs;
+
+nix.buildLisp.library {
+  name = "asdf";
+  srcs = lib.singleton (builtins.toFile "asdf.lisp" "(require 'asdf)");
+}