about summary refs log tree commit diff
path: root/third_party/josh/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/josh/default.nix')
-rw-r--r--third_party/josh/default.nix38
1 files changed, 0 insertions, 38 deletions
diff --git a/third_party/josh/default.nix b/third_party/josh/default.nix
deleted file mode 100644
index c82f91f80c..0000000000
--- a/third_party/josh/default.nix
+++ /dev/null
@@ -1,38 +0,0 @@
-# https://github.com/esrlabs/josh
-{ depot, pkgs, ... }:
-
-let
-  src = pkgs.fetchFromGitHub {
-    owner = "esrlabs";
-    repo = "josh";
-    rev = "effe6290559136faba5591a115e56c2b30210329";
-    hash = "sha256:0kam9rqjk96brvh15wj3h3vm2sqnr5pckz91az2ida5617d5gp9v";
-  };
-in
-depot.third_party.naersk.buildPackage {
-  inherit src;
-
-  buildInputs = with pkgs; [
-    libgit2
-    openssl
-    pkgconfig
-  ];
-
-  cargoBuildOptions = x: x ++ [
-    "-p"
-    "josh"
-    "-p"
-    "josh-proxy"
-    "-p"
-    "josh-ui"
-  ];
-
-  overrideMain = x: {
-    patches = [ ./0001-josh-proxy-Always-require-authentication-when-pushin.patch ];
-
-    nativeBuildInputs = (x.nativeBuildInputs or [ ]) ++ [ pkgs.makeWrapper ];
-    postInstall = ''
-      wrapProgram $out/bin/josh-proxy --prefix PATH : "${pkgs.git}/bin"
-    '';
-  };
-}