about summary refs log tree commit diff
path: root/third_party/gopkgs/go.opencensus.io/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/gopkgs/go.opencensus.io/default.nix')
-rw-r--r--third_party/gopkgs/go.opencensus.io/default.nix11
1 files changed, 7 insertions, 4 deletions
diff --git a/third_party/gopkgs/go.opencensus.io/default.nix b/third_party/gopkgs/go.opencensus.io/default.nix
index b8962df255..b1ee6da1fc 100644
--- a/third_party/gopkgs/go.opencensus.io/default.nix
+++ b/third_party/gopkgs/go.opencensus.io/default.nix
@@ -1,10 +1,13 @@
-{ depot, ... }:
+{ depot, pkgs, ... }:
 
-depot.buildGo.external {
+depot.nix.buildGo.external {
   path = "go.opencensus.io";
-  src = builtins.fetchGit {
-    url = "https://github.com/census-instrumentation/opencensus-go";
+
+  src = pkgs.fetchFromGitHub {
+    owner = "census-instrumentation";
+    repo = "opencensus-go";
     rev = "643eada29081047b355cfaa1ceb9bc307a10423c";
+    sha256 = "1acmv2f5wz06abphk0yvb9igp2j5sn1v21dg1p8n109rwanwd5v4";
   };
 
   deps = with depot.third_party; [