about summary refs log tree commit diff
path: root/third_party/geesefs/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/geesefs/default.nix')
-rw-r--r--third_party/geesefs/default.nix25
1 files changed, 25 insertions, 0 deletions
diff --git a/third_party/geesefs/default.nix b/third_party/geesefs/default.nix
new file mode 100644
index 0000000000..98448bb737
--- /dev/null
+++ b/third_party/geesefs/default.nix
@@ -0,0 +1,25 @@
+# Finally, a good FUSE FS implementation over S3.
+# https://github.com/yandex-cloud/geesefs
+
+{ pkgs, ... }:
+
+pkgs.buildGoModule rec {
+  pname = "geesefs";
+  version = "0.40.1";
+
+  src = pkgs.fetchFromGitHub {
+    owner = "yandex-cloud";
+    repo = "geesefs";
+    rev = "v${version}";
+    hash = "sha256:0ig8h17z8n5j8qb7k2jyh40vv77zazhnz8bxdam9xihxksj8mizp";
+  };
+
+  subPackages = [ "." ];
+  buildInputs = [ pkgs.fuse ];
+  vendorHash = "sha256:11i7cmnlxi00d0csgpv8drfcw0aqshwc4hfs0jw7zwafdhnlyy0j";
+
+  meta = with pkgs.lib; {
+    license = licenses.asl20;
+    maintainers = [ maintainers.tazjin ];
+  };
+}