about summary refs log tree commit diff
path: root/third_party/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/default.nix')
-rw-r--r--third_party/default.nix15
1 files changed, 9 insertions, 6 deletions
diff --git a/third_party/default.nix b/third_party/default.nix
index 7638d98d65..cea0a38a49 100644
--- a/third_party/default.nix
+++ b/third_party/default.nix
@@ -5,11 +5,11 @@
 { ... }:
 
 let
-  # Tracking nixos-unstable as of 2020-12-28.
-  nixpkgsCommit = "2f47650c2f28d87f86ab807b8a339c684d91ec56";
+  # Tracking nixos-unstable as of 2021-01-09.
+  nixpkgsCommit = "f211631c1cb3e94828c7650b5d12c1e5a89e0e16";
   nixpkgsSrc = fetchTarball {
     url = "https://github.com/NixOS/nixpkgs/archive/${nixpkgsCommit}.tar.gz";
-    sha256 = "17akl75x28rzq97gaad32flswdsp150nfsg7h909kda721zql71a";
+    sha256 = "0r085j42991qcbzx4l0hnwlsxw016y4b7r821s4qxvqnvwr9lxar";
   };
   nixpkgs = import nixpkgsSrc {
     config.allowUnfree = true;
@@ -21,11 +21,11 @@ let
     ];
   };
 
-  # Tracking nixos-20.09 as of 2020-12-28.
-  stableCommit = "0c81b9a4f170f734bd7e587a39e56470c59733e7";
+  # Tracking nixos-20.09 as of 2021-01-09.
+  stableCommit = "0cfd08f4881bbfdaa57e68835b923d4290588d98";
   stableNixpkgsSrc = fetchTarball {
     url = "https://github.com/NixOS/nixpkgs/archive/${stableCommit}.tar.gz";
-    sha256 = "1fl5ks6p78bamqanbk9xpy83jzzcdw2mdabrp59n33xv7jix1jzx";
+    sha256 = "1srd9p37jmrsxgvrxvlibmscphz5p42244285yc5piacvrz1rdcc";
   };
   stableNixpkgs = import stableNixpkgsSrc {};
 
@@ -66,6 +66,9 @@ in exposed.lib.fix(self: exposed // {
   emacs27-nox = assert ((exposed.lib.versions.major nixpkgs.emacs.version) == "27");
     nixpkgs.emacs-nox;
 
+  # Provide telega.el from stable
+  stableTelega = stableNixpkgs.emacsPackages.telega;
+
   # The Go authors have released a version of Go (in alpha) that has a
   # type system. This makes it available, specifically for use with
   # //nix/buildTypedGo.