about summary refs log tree commit diff
path: root/third_party/default.nix
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2021-01-09T13·26+0300
committertazjin <mail@tazj.in>2021-01-13T16·53+0000
commitb4e420d4ff3011b8fd515c2cab33fbde55859b8f (patch)
tree8abd2d9d8368c185c6422d0ba776f6a9d2744e37 /third_party/default.nix
parent216e7334f6cc8b9a46a8ebc8be4e081f9580c840 (diff)
chore(3p): Bump NixOS channels to 2021-01-09 r/2078
Your regularly scheduled channel update, but slightly more regular
than before.

Included fixes:

* 3p/emacs: Pick telega.el from stable channel, unstable is broken.
* glittershark/fprintd: Compile with gcc9, since build fails with the
  new default of gcc10
* glittershark/fprintd: Use a global overlay for the fprintd package
  until https://github.com/NixOS/nixpkgs/pull/108962 lands in
  nixos-unstable
* glittershark/home: Don't install rr, as it's not building with gcc10

Co-Author: Griffin Smith <grfn@gws.fyi>
Change-Id: Ia715fef64a405a220049fc540017356fa7370e0b
Reviewed-on: https://cl.tvl.fyi/c/depot/+/2341
Reviewed-by: tazjin <mail@tazj.in>
Reviewed-by: glittershark <grfn@gws.fyi>
Reviewed-by: lukegb <lukegb@tvl.fyi>
Tested-by: BuildkiteCI
Diffstat (limited to 'third_party/default.nix')
-rw-r--r--third_party/default.nix15
1 files changed, 9 insertions, 6 deletions
diff --git a/third_party/default.nix b/third_party/default.nix
index 7638d98d65..cea0a38a49 100644
--- a/third_party/default.nix
+++ b/third_party/default.nix
@@ -5,11 +5,11 @@
 { ... }:
 
 let
-  # Tracking nixos-unstable as of 2020-12-28.
-  nixpkgsCommit = "2f47650c2f28d87f86ab807b8a339c684d91ec56";
+  # Tracking nixos-unstable as of 2021-01-09.
+  nixpkgsCommit = "f211631c1cb3e94828c7650b5d12c1e5a89e0e16";
   nixpkgsSrc = fetchTarball {
     url = "https://github.com/NixOS/nixpkgs/archive/${nixpkgsCommit}.tar.gz";
-    sha256 = "17akl75x28rzq97gaad32flswdsp150nfsg7h909kda721zql71a";
+    sha256 = "0r085j42991qcbzx4l0hnwlsxw016y4b7r821s4qxvqnvwr9lxar";
   };
   nixpkgs = import nixpkgsSrc {
     config.allowUnfree = true;
@@ -21,11 +21,11 @@ let
     ];
   };
 
-  # Tracking nixos-20.09 as of 2020-12-28.
-  stableCommit = "0c81b9a4f170f734bd7e587a39e56470c59733e7";
+  # Tracking nixos-20.09 as of 2021-01-09.
+  stableCommit = "0cfd08f4881bbfdaa57e68835b923d4290588d98";
   stableNixpkgsSrc = fetchTarball {
     url = "https://github.com/NixOS/nixpkgs/archive/${stableCommit}.tar.gz";
-    sha256 = "1fl5ks6p78bamqanbk9xpy83jzzcdw2mdabrp59n33xv7jix1jzx";
+    sha256 = "1srd9p37jmrsxgvrxvlibmscphz5p42244285yc5piacvrz1rdcc";
   };
   stableNixpkgs = import stableNixpkgsSrc {};
 
@@ -66,6 +66,9 @@ in exposed.lib.fix(self: exposed // {
   emacs27-nox = assert ((exposed.lib.versions.major nixpkgs.emacs.version) == "27");
     nixpkgs.emacs-nox;
 
+  # Provide telega.el from stable
+  stableTelega = stableNixpkgs.emacsPackages.telega;
+
   # The Go authors have released a version of Go (in alpha) that has a
   # type system. This makes it available, specifically for use with
   # //nix/buildTypedGo.