about summary refs log tree commit diff
path: root/third_party/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/default.nix')
-rw-r--r--third_party/default.nix15
1 files changed, 10 insertions, 5 deletions
diff --git a/third_party/default.nix b/third_party/default.nix
index f8881fac81..b795f5c24b 100644
--- a/third_party/default.nix
+++ b/third_party/default.nix
@@ -5,11 +5,11 @@
 { ... }:
 
 let
-  # Tracking nixos-unstable as of 2020-08-16.
-  nixpkgsCommit = "16fc531784ac226fb268cc59ad573d2746c109c1";
+  # Tracking nixos-unstable as of 2020-11-21.
+  nixpkgsCommit = "a322b32e9d74fb476944ff6cfb55833dc69cfaaa";
   nixpkgsSrc = fetchTarball {
-    url = "https://github.com/NixOS/nixpkgs-channels/archive/${nixpkgsCommit}.tar.gz";
-    sha256 = "0qw1jpdfih9y0dycslapzfp8bl4z7vfg9c7qz176wghwybm4sx0a";
+    url = "https://github.com/NixOS/nixpkgs/archive/${nixpkgsCommit}.tar.gz";
+    sha256 = "1r0mkiqxija75spnyksmh8x5j4smnrxv5f7768s81gsl570kls0l";
   };
   nixpkgs = import nixpkgsSrc {
     config.allowUnfree = true;
@@ -38,7 +38,6 @@ let
       autoreconfHook
       avrdude
       avrlibc
-      awscli
       bashInteractive
       bat
       buildBazelPackage
@@ -159,6 +158,12 @@ let
       zlib
       zstd;
 
+    # Inherit packages from the stable channel for things that are
+    # broken on unstable
+    inherit (stableNixpkgs)
+      awscli # TODO(grfn): Move back to unstable once it is fixed
+      ;
+
     # Required by //third_party/nix
     inherit (nixpkgs)
       aws-sdk-cpp