about summary refs log tree commit diff
path: root/third_party/default.nix
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2020-11-21T17·22+0100
committertazjin <mail@tazj.in>2020-11-21T23·18+0000
commit5a00e58904df83c168f3971984916d479277e409 (patch)
tree183ffc507c3a720c4c97b760dc75fa1d6141060a /third_party/default.nix
parente9088826109dfcc550f599ccdc7926a0eed1cd50 (diff)
chore(3p): Bump nixpkgs to nixos-unstable from 2020-11-21 r/1894
Included fixes for random breakage:

* 3p/awscli: pick from the stable channel; it is broken on unstable
* 3p/googletest: bumped version & removed patches that nixpkgs applies
* 3p/lisp/cffi: bumped library version for SBCL compat
* 3p/nix: fix libsystemd attribute
* 3p/nix: reformatted (clang-format handling of ternaries changed)
* glittershark/home: Use home-manager from nixkpgs
* glittershark/kernel: bumped linux-ck patch hash
* glittershark/kernel: removed "patch patch"
* multi/whitby: Use home-manager from nixpkgs
* tazjin/frog: drop Sourcetrail (it doesn't build currently)

Note that in addition to these changes, some previous CLs updated the
versions of git and cgit which was necessary for this channel bump,
but which could not be done in the same commit due to the nature of
the subtree merges.

Change-Id: If2563e8a68e2750c4b913a976ff7b93b42e8b7f3
Reviewed-on: https://cl.tvl.fyi/c/depot/+/2110
Tested-by: BuildkiteCI
Reviewed-by: multi <depot@in-addr.xyz>
Reviewed-by: glittershark <grfn@gws.fyi>
Diffstat (limited to 'third_party/default.nix')
-rw-r--r--third_party/default.nix15
1 files changed, 10 insertions, 5 deletions
diff --git a/third_party/default.nix b/third_party/default.nix
index f8881fac81..b795f5c24b 100644
--- a/third_party/default.nix
+++ b/third_party/default.nix
@@ -5,11 +5,11 @@
 { ... }:
 
 let
-  # Tracking nixos-unstable as of 2020-08-16.
-  nixpkgsCommit = "16fc531784ac226fb268cc59ad573d2746c109c1";
+  # Tracking nixos-unstable as of 2020-11-21.
+  nixpkgsCommit = "a322b32e9d74fb476944ff6cfb55833dc69cfaaa";
   nixpkgsSrc = fetchTarball {
-    url = "https://github.com/NixOS/nixpkgs-channels/archive/${nixpkgsCommit}.tar.gz";
-    sha256 = "0qw1jpdfih9y0dycslapzfp8bl4z7vfg9c7qz176wghwybm4sx0a";
+    url = "https://github.com/NixOS/nixpkgs/archive/${nixpkgsCommit}.tar.gz";
+    sha256 = "1r0mkiqxija75spnyksmh8x5j4smnrxv5f7768s81gsl570kls0l";
   };
   nixpkgs = import nixpkgsSrc {
     config.allowUnfree = true;
@@ -38,7 +38,6 @@ let
       autoreconfHook
       avrdude
       avrlibc
-      awscli
       bashInteractive
       bat
       buildBazelPackage
@@ -159,6 +158,12 @@ let
       zlib
       zstd;
 
+    # Inherit packages from the stable channel for things that are
+    # broken on unstable
+    inherit (stableNixpkgs)
+      awscli # TODO(grfn): Move back to unstable once it is fixed
+      ;
+
     # Required by //third_party/nix
     inherit (nixpkgs)
       aws-sdk-cpp