about summary refs log tree commit diff
path: root/third_party/cgit/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/cgit/default.nix')
-rw-r--r--third_party/cgit/default.nix46
1 files changed, 30 insertions, 16 deletions
diff --git a/third_party/cgit/default.nix b/third_party/cgit/default.nix
index 3e58816fc7..c783bda16e 100644
--- a/third_party/cgit/default.nix
+++ b/third_party/cgit/default.nix
@@ -1,37 +1,51 @@
-{ depot, ... }:
+{ depot, lib, pkgs, ... }:
 
 let
-  inherit (depot.third_party) stdenv gzip bzip2 xz luajit zlib autoconf openssl pkgconfig;
-in stdenv.mkDerivation rec {
-  pname = "cgit";
+  inherit (pkgs) stdenv gzip bzip2 xz lzip zstd zlib openssl;
+in
+stdenv.mkDerivation rec {
+  pname = "cgit-pink";
   version = "master";
   src = ./.;
 
-  nativeBuildInputs = [ autoconf pkgconfig ];
-  buildInputs = [ openssl zlib luajit ];
+  buildInputs = [ openssl zlib ];
+
+  enableParallelBuilding = true;
 
   postPatch = ''
     sed -e 's|"gzip"|"${gzip}/bin/gzip"|' \
         -e 's|"bzip2"|"${bzip2.bin}/bin/bzip2"|' \
+        -e 's|"lzip"|"${lzip}/bin/lzip"|' \
         -e 's|"xz"|"${xz.bin}/bin/xz"|' \
+        -e 's|"zstd"|"${zstd}/bin/zstd"|' \
         -i ui-snapshot.c
   '';
 
-  # Give cgit the git source tree from the depot. Note that the
-  # versions should be kept in sync (see the Makefile for the current
-  # git version).
+  # Give cgit the git source tree including depot patches. Note that
+  # the version expected by cgit should be kept in sync with the
+  # version available in nixpkgs.
+  #
+  # TODO(tazjin): Add an assert for this somewhere so we notice it on
+  # channel bumps.
   preBuild = ''
     rm -rf git # remove submodule dir ...
-    cp -r --no-preserve=ownership,mode ${depot.third_party.git.src} git
+    cp -r --no-preserve=ownership,mode ${pkgs.srcOnly depot.third_party.git} git
     makeFlagsArray+=(prefix="$out" CGIT_SCRIPT_PATH="$out/cgit/")
+    cat tvl-extra.css >> cgit.css
+  '';
+
+  stripDebugList = [ "cgit" ];
+
+  # We don't use the filters and they require wrapping to find their deps
+  postInstall = ''
+    rm -rf "$out/lib/cgit/filters"
+    find "$out" -type d -empty -delete
   '';
 
   meta = {
-    homepage = https://git.zx2c4.com/cgit/about/;
-    repositories.git = git://git.zx2c4.com/cgit;
-    description = "Web frontend for git repositories";
-    license = stdenv.lib.licenses.gpl2;
-    platforms = stdenv.lib.platforms.linux;
-    maintainers = with stdenv.lib.maintainers; [ bjornfor ];
+    hompepage = "https://git.causal.agency/cgit-pink/";
+    description = "cgit fork aiming for better maintenance";
+    license = lib.licenses.gpl2;
+    platforms = lib.platforms.linux;
   };
 }