about summary refs log tree commit diff
path: root/third_party/abseil_cpp/absl/meta/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/abseil_cpp/absl/meta/CMakeLists.txt')
-rw-r--r--third_party/abseil_cpp/absl/meta/CMakeLists.txt50
1 files changed, 0 insertions, 50 deletions
diff --git a/third_party/abseil_cpp/absl/meta/CMakeLists.txt b/third_party/abseil_cpp/absl/meta/CMakeLists.txt
deleted file mode 100644
index 672ead2fd0..0000000000
--- a/third_party/abseil_cpp/absl/meta/CMakeLists.txt
+++ /dev/null
@@ -1,50 +0,0 @@
-#
-# Copyright 2017 The Abseil Authors.
-#
-# Licensed under the Apache License, Version 2.0 (the "License");
-# you may not use this file except in compliance with the License.
-# You may obtain a copy of the License at
-#
-#      https://www.apache.org/licenses/LICENSE-2.0
-#
-# Unless required by applicable law or agreed to in writing, software
-# distributed under the License is distributed on an "AS IS" BASIS,
-# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
-# See the License for the specific language governing permissions and
-# limitations under the License.
-#
-
-absl_cc_library(
-  NAME
-    type_traits
-  HDRS
-    "type_traits.h"
-  COPTS
-    ${ABSL_DEFAULT_COPTS}
-  DEPS
-    absl::config
-  PUBLIC
-)
-
-absl_cc_test(
-  NAME
-    type_traits_test
-  SRCS
-    "type_traits_test.cc"
-  COPTS
-    ${ABSL_TEST_COPTS}
-  DEPS
-    absl::type_traits
-    gmock_main
-)
-
-# component target
-absl_cc_library(
-  NAME
-    meta
-  COPTS
-    ${ABSL_DEFAULT_COPTS}
-  DEPS
-    absl::type_traits
-  PUBLIC
-)