about summary refs log tree commit diff
path: root/tests/sandbox.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tests/sandbox.nix')
-rw-r--r--tests/sandbox.nix3
1 files changed, 2 insertions, 1 deletions
diff --git a/tests/sandbox.nix b/tests/sandbox.nix
index 7e2055038c..dc72a5985e 100644
--- a/tests/sandbox.nix
+++ b/tests/sandbox.nix
@@ -16,7 +16,7 @@ let
 
   sandboxTestScript = pkgs.writeText "sandbox-testscript.sh" ''
     [ $(id -u) -eq 0 ]
-    touch foo
+    cp -p "$testfile" foo
     chown 1024:1024 foo
     touch "$out"
   '';
@@ -31,6 +31,7 @@ let
       builder = "''${utils}/bin/bash";
       args = ["-e" ${sandboxTestScript}];
       PATH = "''${utils}/bin";
+      testfile = builtins.toFile "test" "i am a test file";
     }
   '';