about summary refs log tree commit diff
path: root/system/modules/common.nix
diff options
context:
space:
mode:
Diffstat (limited to 'system/modules/common.nix')
-rw-r--r--system/modules/common.nix10
1 files changed, 10 insertions, 0 deletions
diff --git a/system/modules/common.nix b/system/modules/common.nix
index fd646aa4a1..2aa487cdf1 100644
--- a/system/modules/common.nix
+++ b/system/modules/common.nix
@@ -116,3 +116,13 @@
     # gc = {
     #   automatic = true;
     #   dates = "
+  };
+
+  services.udev.extraRules = ''
+    # UDEV rules for Teensy USB devices
+    ATTRS{idVendor}=="16c0", ATTRS{idProduct}=="04[789B]?", ENV{ID_MM_DEVICE_IGNORE}="1"
+    ATTRS{idVendor}=="16c0", ATTRS{idProduct}=="04[789A]?", ENV{MTP_NO_PROBE}="1"
+    SUBSYSTEMS=="usb", ATTRS{idVendor}=="16c0", ATTRS{idProduct}=="04[789ABCD]?", MODE:="0666"
+    KERNEL=="ttyACM*", ATTRS{idVendor}=="16c0", ATTRS{idProduct}=="04[789B]?", MODE:="0666"
+  '';
+}