about summary refs log tree commit diff
path: root/system/modules/common.nix
diff options
context:
space:
mode:
authorGriffin Smith <root@gws.fyi>2020-05-08T15·57-0400
committerGriffin Smith <root@gws.fyi>2020-05-08T15·57-0400
commitf8d43c8143ca07e8aecc499e86cba5f114beae55 (patch)
treef396891f0536c6afc157e6ffe7401a27e0e2211c /system/modules/common.nix
parent02777331ed00a576f39916a4f788b76ce615e916 (diff)
udev rules for ergodox
Diffstat (limited to 'system/modules/common.nix')
-rw-r--r--system/modules/common.nix10
1 files changed, 10 insertions, 0 deletions
diff --git a/system/modules/common.nix b/system/modules/common.nix
index fd646aa4a1..2aa487cdf1 100644
--- a/system/modules/common.nix
+++ b/system/modules/common.nix
@@ -116,3 +116,13 @@
     # gc = {
     #   automatic = true;
     #   dates = "
+  };
+
+  services.udev.extraRules = ''
+    # UDEV rules for Teensy USB devices
+    ATTRS{idVendor}=="16c0", ATTRS{idProduct}=="04[789B]?", ENV{ID_MM_DEVICE_IGNORE}="1"
+    ATTRS{idVendor}=="16c0", ATTRS{idProduct}=="04[789A]?", ENV{MTP_NO_PROBE}="1"
+    SUBSYSTEMS=="usb", ATTRS{idVendor}=="16c0", ATTRS{idProduct}=="04[789ABCD]?", MODE:="0666"
+    KERNEL=="ttyACM*", ATTRS{idVendor}=="16c0", ATTRS{idProduct}=="04[789B]?", MODE:="0666"
+  '';
+}