about summary refs log tree commit diff
path: root/services/gemma/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'services/gemma/default.nix')
-rw-r--r--services/gemma/default.nix12
1 files changed, 5 insertions, 7 deletions
diff --git a/services/gemma/default.nix b/services/gemma/default.nix
index 8c56e56685..537875b625 100644
--- a/services/gemma/default.nix
+++ b/services/gemma/default.nix
@@ -1,15 +1,9 @@
-with import <nixpkgs> {};
+{ stdenv, sbcl, lispPackages, elmPackages, pkgconfig }:
 
 stdenv.mkDerivation rec {
   name = "gemma";
-
   src = ./.;
 
-  # For the time being, Gemma can not be built because it requires an
-  # older version of Elm than what is available and Elm upgrade paths
-  # are painful.
-  broken = true;
-
   buildInputs = with lispPackages; [
     sbcl
     quicklisp
@@ -50,5 +44,9 @@ stdenv.mkDerivation rec {
     description = "Tool for tracking recurring tasks";
     homepage    = "https://github.com/tazjin/gemma";
     license     = licenses.gpl3;
+
+    # For the time being, Gemma can not be built because the Lisp build process
+    # broke in some way I haven't had time to debug.
+    broken = true;
   };
 }