about summary refs log tree commit diff
path: root/read-tree.nix
diff options
context:
space:
mode:
Diffstat (limited to 'read-tree.nix')
-rw-r--r--read-tree.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/read-tree.nix b/read-tree.nix
index 8aa504efc2..ba3fd99f81 100644
--- a/read-tree.nix
+++ b/read-tree.nix
@@ -65,7 +65,7 @@ let
     let nixFiles = filterNixFiles dir;
         imported = map (f: {
           inherit (f) name;
-          value = import (joinPath path f.value) args;
+          value = import (joinPath path f.value) (argsWithPath args (pathParts path));
         }) nixFiles;
         dirs = map (d: {
           inherit (d) name;