about summary refs log tree commit diff
path: root/read-tree.nix
diff options
context:
space:
mode:
authorVincent Ambo <tazjin@google.com>2019-12-09T12·22+0000
committerVincent Ambo <tazjin@google.com>2019-12-09T12·22+0000
commit124e185628adc20e4cb9bb022181dfbd061aa340 (patch)
tree31b976bef222958f8b442fa4242198305ab18141 /read-tree.nix
parent514c48fdde64659bb66aa35b50f0339275b3722a (diff)
fix(read-tree): Always import with `locatedAt` attribute r/113
Diffstat (limited to 'read-tree.nix')
-rw-r--r--read-tree.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/read-tree.nix b/read-tree.nix
index 8aa504efc2..ba3fd99f81 100644
--- a/read-tree.nix
+++ b/read-tree.nix
@@ -65,7 +65,7 @@ let
     let nixFiles = filterNixFiles dir;
         imported = map (f: {
           inherit (f) name;
-          value = import (joinPath path f.value) args;
+          value = import (joinPath path f.value) (argsWithPath args (pathParts path));
         }) nixFiles;
         dirs = map (d: {
           inherit (d) name;