about summary refs log tree commit diff
path: root/presentations/bootstrapping-2018/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'presentations/bootstrapping-2018/default.nix')
-rw-r--r--presentations/bootstrapping-2018/default.nix15
1 files changed, 9 insertions, 6 deletions
diff --git a/presentations/bootstrapping-2018/default.nix b/presentations/bootstrapping-2018/default.nix
index c4ac8a472a..28296d8bf3 100644
--- a/presentations/bootstrapping-2018/default.nix
+++ b/presentations/bootstrapping-2018/default.nix
@@ -1,8 +1,10 @@
 # This derivation builds the LaTeX presentation.
 
-{ pkgs ? import <nixpkgs> {} }:
+{ pkgs, ... }:
 
-with pkgs; let tex = texlive.combine {
+with pkgs.third_party;
+
+let tex = texlive.combine {
   inherit (texlive)
     beamer
     beamertheme-metropolis
@@ -13,14 +15,14 @@ with pkgs; let tex = texlive.combine {
     lualibs
     luaotfload
     luatex
-    luatex-def
     minted
     ms
     pgfopts
-    scheme-basic;
+    scheme-basic
+    translator;
 };
 in stdenv.mkDerivation {
-  name = "nuug-reproducible-slides.pdf";
+  name = "nuug-bootstrapping-slides";
   src = ./.;
 
   FONTCONFIG_FILE = makeFontsConf {
@@ -42,6 +44,7 @@ in stdenv.mkDerivation {
   '';
 
   installPhase = ''
-    cp presentation.pdf $out
+    mkdir -p $out
+    cp presentation.pdf $out/
   '';
 }