about summary refs log tree commit diff
path: root/ops/nixos/dotfiles.nix
diff options
context:
space:
mode:
Diffstat (limited to 'ops/nixos/dotfiles.nix')
-rw-r--r--ops/nixos/dotfiles.nix27
1 files changed, 0 insertions, 27 deletions
diff --git a/ops/nixos/dotfiles.nix b/ops/nixos/dotfiles.nix
deleted file mode 100644
index 2e952207d4..0000000000
--- a/ops/nixos/dotfiles.nix
+++ /dev/null
@@ -1,27 +0,0 @@
-# Bundle configuration files into a derivation.
-# I call this derivation dotfiles despite that not technically being true
-# anymore ...
-
-{ config, pkgs, ...}:
-
-let dotfiles = pkgs.stdenv.mkDerivation {
-  name = "tazjins-dotfiles";
-
-  srcs = [
-    ./dotfiles
-  ];
-
-  installPhase = ''
-    mkdir -p $out
-    cp ./* $out/
-  '';
-};
-in {
-  # /etc/ is a special place in NixOS!
-  # Symlinks that need to be created there must be specified explicitly.
-  environment.etc = {
-    "alacritty.yml".source    = "${dotfiles}/alacritty.yml";
-    "fish/config.fish".source = "${dotfiles}/config.fish";
-    "tmux.conf".source        = "${dotfiles}/tmux.conf";
-  };
-}