about summary refs log tree commit diff
path: root/ops/nixos/depot.nix
diff options
context:
space:
mode:
Diffstat (limited to 'ops/nixos/depot.nix')
-rw-r--r--ops/nixos/depot.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/ops/nixos/depot.nix b/ops/nixos/depot.nix
new file mode 100644
index 0000000000..2c1b71a2da
--- /dev/null
+++ b/ops/nixos/depot.nix
@@ -0,0 +1,16 @@
+# This module makes it possible to get at the depot from "proper"
+# NixOS modules.
+#
+# It needs to be included and configured in each system like this:
+#
+# {
+#   imports = [ "${depot.depotPath}/ops/nixos/depot.nix" ];
+#   inherit depot;
+# }
+{ lib, ... }:
+
+{
+  options.depot = with lib; mkOption {
+    description = "tazjin's imported monorepo";
+  };
+}