about summary refs log tree commit diff
path: root/ops/nixos/depot.nix
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2020-06-13T20·52+0100
committertazjin <mail@tazj.in>2020-06-13T23·52+0000
commit268729083eb80c93aa402883085c37e32c8a08cf (patch)
tree0916bace8073d30976ec752bb9de8c19a06027ae /ops/nixos/depot.nix
parent9658e96a87178e972b656db0acf3219937013b88 (diff)
refactor(ops/nixos): Move my NixOS configurations to //users/tazjin r/941
NixOS modules move one level up because it's unlikely that //ops/nixos
will contain actual systems at this point (they're user-specific).

This is the first users folder, so it is also added to the root
readTree invocation for the repository.

Change-Id: I546c701145fa204b7ba7518a8a56a783588629e0
Reviewed-on: https://cl.tvl.fyi/c/depot/+/244
Reviewed-by: tazjin <mail@tazj.in>
Diffstat (limited to 'ops/nixos/depot.nix')
-rw-r--r--ops/nixos/depot.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/ops/nixos/depot.nix b/ops/nixos/depot.nix
new file mode 100644
index 0000000000..2c1b71a2da
--- /dev/null
+++ b/ops/nixos/depot.nix
@@ -0,0 +1,16 @@
+# This module makes it possible to get at the depot from "proper"
+# NixOS modules.
+#
+# It needs to be included and configured in each system like this:
+#
+# {
+#   imports = [ "${depot.depotPath}/ops/nixos/depot.nix" ];
+#   inherit depot;
+# }
+{ lib, ... }:
+
+{
+  options.depot = with lib; mkOption {
+    description = "tazjin's imported monorepo";
+  };
+}