about summary refs log tree commit diff
path: root/ops/nixos/camden/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'ops/nixos/camden/default.nix')
-rw-r--r--ops/nixos/camden/default.nix24
1 files changed, 21 insertions, 3 deletions
diff --git a/ops/nixos/camden/default.nix b/ops/nixos/camden/default.nix
index 9a960600db..d1d601ecb0 100644
--- a/ops/nixos/camden/default.nix
+++ b/ops/nixos/camden/default.nix
@@ -7,6 +7,8 @@ config: let
     config.allowUnfree = true;
   };
 in pkgs.lib.fix(self: {
+  imports = [ ../modules/tailscale.nix ];
+
   # camden is intended to boot unattended, despite having an encrypted
   # root partition.
   #
@@ -72,9 +74,17 @@ in pkgs.lib.fix(self: {
 
   # System-wide application setup
   programs.fish.enable = true;
-  environment.systemPackages = with nixpkgs; [
-    curl emacs26-nox git gnupg pass pciutils
-  ];
+  environment.systemPackages =
+    # programs from the depot
+    (with pkgs; [
+      third_party.git
+      third_party.tailscale
+    ]) ++
+
+    # programs from nixpkgs
+    (with nixpkgs; [
+      curl emacs26-nox gnupg pass pciutils direnv
+    ]);
 
   # Services setup
   services.openssh.enable = true;
@@ -86,5 +96,13 @@ in pkgs.lib.fix(self: {
     shell = nixpkgs.fish;
   };
 
+  # Join Tailscale into home network
+  services.tailscale = {
+    enable = true;
+    relayConf = "/etc/tailscale.conf";
+    aclFile = null; # allow all traffic for testing
+    package = pkgs.third_party.tailscale;
+  };
+
   system.stateVersion = "19.09";
 })