about summary refs log tree commit diff
path: root/ops/modules/www/tvix.dev.nix
diff options
context:
space:
mode:
Diffstat (limited to 'ops/modules/www/tvix.dev.nix')
-rw-r--r--ops/modules/www/tvix.dev.nix17
1 files changed, 17 insertions, 0 deletions
diff --git a/ops/modules/www/tvix.dev.nix b/ops/modules/www/tvix.dev.nix
index f86f5b3b1e..33c0bb002c 100644
--- a/ops/modules/www/tvix.dev.nix
+++ b/ops/modules/www/tvix.dev.nix
@@ -17,6 +17,23 @@
       '';
     };
 
+    services.nginx.virtualHosts."bolt.tvix.dev" = {
+      root = depot.web.tvixbolt;
+      enableACME = true;
+      forceSSL = true;
+
+      extraConfig = ''
+        add_header Strict-Transport-Security "max-age=31536000; includeSubDomains; preload" always;
+      '';
+    };
+
+    # old domain, serve redirect
+    services.nginx.virtualHosts."tvixbolt.tvl.su" = {
+      enableACME = true;
+      forceSSL = true;
+      extraConfig = "return 301 https://bolt.tvix.dev$request_uri;";
+    };
+
     services.nginx.virtualHosts."docs.tvix.dev" = {
       serverName = "docs.tvix.dev";
       enableACME = true;