about summary refs log tree commit diff
path: root/ops/modules/tvl-sso/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'ops/modules/tvl-sso/default.nix')
-rw-r--r--ops/modules/tvl-sso/default.nix28
1 files changed, 0 insertions, 28 deletions
diff --git a/ops/modules/tvl-sso/default.nix b/ops/modules/tvl-sso/default.nix
deleted file mode 100644
index 8b413114cc..0000000000
--- a/ops/modules/tvl-sso/default.nix
+++ /dev/null
@@ -1,28 +0,0 @@
-# Configures an Apereo CAS instance for TVL SSO
-{ depot, ... }:
-
-let
-  inherit (depot.third_party) apereo-cas;
-in {
-  config = {
-    environment.systemPackages = [ apereo-cas ];
-    systemd.services.apereo-cas = {
-      description = "Apereo CAS Single Sign On server";
-      wantedBy = [ "multi-user.target" ];
-      after = [ "network.target" ];
-      environment.JDK_JAVA_OPTIONS = "-Xmx512M -Xms512M";
-      serviceConfig = {
-        User = "apereo-cas";
-        Group = "apereo-cas";
-        ExecStart = "${apereo-cas}/bin/cas";
-        EnvironmentFile = "/etc/cas/secrets";
-        Restart = "always";
-      };
-    };
-    users.users.apereo-cas = {
-      isSystemUser = true;
-      group = "apereo-cas";
-    };
-    users.groups.apereo-cas = {};
-  };
-}