about summary refs log tree commit diff
path: root/ops/modules/tvl-buildkite.nix
diff options
context:
space:
mode:
Diffstat (limited to 'ops/modules/tvl-buildkite.nix')
-rw-r--r--ops/modules/tvl-buildkite.nix5
1 files changed, 4 insertions, 1 deletions
diff --git a/ops/modules/tvl-buildkite.nix b/ops/modules/tvl-buildkite.nix
index 4341ef01d7..3c6d88404f 100644
--- a/ops/modules/tvl-buildkite.nix
+++ b/ops/modules/tvl-buildkite.nix
@@ -13,7 +13,7 @@ let
 
   # All Buildkite hooks are actually besadii, but it's being invoked
   # with different names.
-  buildkiteHooks = pkgs.runCommandNoCC "buildkite-hooks" { } ''
+  buildkiteHooks = pkgs.runCommand "buildkite-hooks" { } ''
     mkdir -p $out/bin
     ln -s ${besadiiWithConfig "post-command"} $out/bin/post-command
   '';
@@ -43,6 +43,9 @@ in
           tokenPath = config.age.secretsDir + "/buildkite-agent-token";
           privateSshKeyPath = config.age.secretsDir + "/buildkite-private-key";
           hooks.post-command = "${buildkiteHooks}/bin/post-command";
+          hooks.environment = ''
+            export PATH=$PATH:/run/wrappers/bin
+          '';
 
           runtimePackages = with pkgs; [
             bash