about summary refs log tree commit diff
path: root/ops/modules/sourcegraph.nix
diff options
context:
space:
mode:
Diffstat (limited to 'ops/modules/sourcegraph.nix')
-rw-r--r--ops/modules/sourcegraph.nix8
1 files changed, 5 insertions, 3 deletions
diff --git a/ops/modules/sourcegraph.nix b/ops/modules/sourcegraph.nix
index a72cd75d47..cbf836ab64 100644
--- a/ops/modules/sourcegraph.nix
+++ b/ops/modules/sourcegraph.nix
@@ -4,7 +4,8 @@
 
 let
   cfg = config.services.depot.sourcegraph;
-in {
+in
+{
   options.services.depot.sourcegraph = with lib; {
     enable = mkEnableOption "SourceGraph code search engine";
 
@@ -34,7 +35,7 @@ in {
     };
 
     virtualisation.oci-containers.containers.sourcegraph = {
-      image = "sourcegraph/server:3.31.2";
+      image = "sourcegraph/server:3.40.0";
 
       ports = [
         "127.0.0.1:${toString cfg.port}:7080"
@@ -51,7 +52,8 @@ in {
       # Sourcegraph needs a higher nofile limit, it logs warnings
       # otherwise (unclear whether it actually affects the service).
       extraOptions = [
-        "--ulimit" "nofile=10000:10000"
+        "--ulimit"
+        "nofile=10000:10000"
       ];
     };
   };