about summary refs log tree commit diff
path: root/ops/modules/panettone.nix
diff options
context:
space:
mode:
Diffstat (limited to 'ops/modules/panettone.nix')
-rw-r--r--ops/modules/panettone.nix11
1 files changed, 11 insertions, 0 deletions
diff --git a/ops/modules/panettone.nix b/ops/modules/panettone.nix
index 2576ab16c5..e23dd028ab 100644
--- a/ops/modules/panettone.nix
+++ b/ops/modules/panettone.nix
@@ -104,5 +104,16 @@ in
         ISSUECHANNEL = cfg.irccatChannel;
       };
     };
+
+    systemd.services.panettone-fixer = {
+      description = "Restart panettone regularly to work around b/225";
+      wantedBy = [ "multi-user.target" ];
+      script = "${pkgs.systemd}/bin/systemctl restart panettone";
+      serviceConfig.Type = "oneshot";
+
+      # We don't exactly know how frequently this occurs, but
+      # _probably_ not more than hourly.
+      startAt = "hourly";
+    };
   };
 }