about summary refs log tree commit diff
path: root/ops/modules/panettone.nix
diff options
context:
space:
mode:
Diffstat (limited to 'ops/modules/panettone.nix')
-rw-r--r--ops/modules/panettone.nix13
1 files changed, 12 insertions, 1 deletions
diff --git a/ops/modules/panettone.nix b/ops/modules/panettone.nix
index d57e53e754..e23dd028ab 100644
--- a/ops/modules/panettone.nix
+++ b/ops/modules/panettone.nix
@@ -37,7 +37,7 @@ in
         by systemd's EnvironmentFile
       '';
       type = types.str;
-      default = "/run/agenix/panettone";
+      default = config.age.secretsDir + "/panettone";
     };
 
     irccatHost = mkOption {
@@ -104,5 +104,16 @@ in
         ISSUECHANNEL = cfg.irccatChannel;
       };
     };
+
+    systemd.services.panettone-fixer = {
+      description = "Restart panettone regularly to work around b/225";
+      wantedBy = [ "multi-user.target" ];
+      script = "${pkgs.systemd}/bin/systemctl restart panettone";
+      serviceConfig.Type = "oneshot";
+
+      # We don't exactly know how frequently this occurs, but
+      # _probably_ not more than hourly.
+      startAt = "hourly";
+    };
   };
 }