about summary refs log tree commit diff
path: root/ops/modules/owothia.nix
diff options
context:
space:
mode:
Diffstat (limited to 'ops/modules/owothia.nix')
-rw-r--r--ops/modules/owothia.nix5
1 files changed, 3 insertions, 2 deletions
diff --git a/ops/modules/owothia.nix b/ops/modules/owothia.nix
index b2a77cddc2..b9746c1720 100644
--- a/ops/modules/owothia.nix
+++ b/ops/modules/owothia.nix
@@ -4,14 +4,15 @@
 let
   cfg = config.services.depot.owothia;
   description = "owothia - i'm a service owo";
-in {
+in
+{
   options.services.depot.owothia = {
     enable = lib.mkEnableOption description;
 
     secretsFile = lib.mkOption {
       type = lib.types.str;
       description = "File path from which systemd should read secrets";
-      default = "/run/agenix/owothia";
+      default = config.age.secretsDir + "/owothia";
     };
 
     owoChance = lib.mkOption {