about summary refs log tree commit diff
path: root/ops/modules/default-imports.nix
diff options
context:
space:
mode:
Diffstat (limited to 'ops/modules/default-imports.nix')
-rw-r--r--ops/modules/default-imports.nix14
1 files changed, 14 insertions, 0 deletions
diff --git a/ops/modules/default-imports.nix b/ops/modules/default-imports.nix
new file mode 100644
index 0000000000..11514a437a
--- /dev/null
+++ b/ops/modules/default-imports.nix
@@ -0,0 +1,14 @@
+{ depot, ... }:
+
+# Default set of modules that are imported in all Depot nixos systems
+#
+# All modules here should be properly gated behind a `lib.mkEnableOption` with a
+# `lib.mkIf` for the config.
+
+{
+  imports = [
+    ./automatic-gc.nix
+    ./auto-deploy.nix
+    ./tvl-cache.nix
+  ];
+}