about summary refs log tree commit diff
path: root/ops/modules/atward.nix
diff options
context:
space:
mode:
Diffstat (limited to 'ops/modules/atward.nix')
-rw-r--r--ops/modules/atward.nix8
1 files changed, 7 insertions, 1 deletions
diff --git a/ops/modules/atward.nix b/ops/modules/atward.nix
index 672b85e87d..354f9ebdd3 100644
--- a/ops/modules/atward.nix
+++ b/ops/modules/atward.nix
@@ -7,6 +7,12 @@ in {
   options.services.depot.atward = {
     enable = lib.mkEnableOption description;
 
+    host = lib.mkOption {
+      type = lib.types.str;
+      default = "[::1]";
+      description = "Host on which atward should listen";
+    };
+
     port = lib.mkOption {
       type = lib.types.int;
       default = 28973;
@@ -25,7 +31,7 @@ in {
         Restart = "always";
       };
 
-      environment.ATWARD_PORT = toString cfg.port;
+      environment.ATWARD_LISTEN_ADDRESS = "${cfg.host}:${toString cfg.port}";
     };
   };
 }