about summary refs log tree commit diff
path: root/nix/writeScriptBin/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix/writeScriptBin/default.nix')
-rw-r--r--nix/writeScriptBin/default.nix12
1 files changed, 12 insertions, 0 deletions
diff --git a/nix/writeScriptBin/default.nix b/nix/writeScriptBin/default.nix
new file mode 100644
index 0000000000..ed26cf197e
--- /dev/null
+++ b/nix/writeScriptBin/default.nix
@@ -0,0 +1,12 @@
+{ depot, ... }:
+
+# Like writeScript,
+# but put the script into `$out/bin/${name}`.
+
+name:
+script:
+
+depot.nix.binify {
+  exe = (depot.nix.writeScript name script);
+  inherit name;
+}