about summary refs log tree commit diff
path: root/nix/writeElispBin/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix/writeElispBin/default.nix')
-rw-r--r--nix/writeElispBin/default.nix8
1 files changed, 5 insertions, 3 deletions
diff --git a/nix/writeElispBin/default.nix b/nix/writeElispBin/default.nix
index c116607e0a..3ea2da58aa 100644
--- a/nix/writeElispBin/default.nix
+++ b/nix/writeElispBin/default.nix
@@ -1,6 +1,6 @@
 { depot, pkgs, ... }:
 
-{ name, src, deps ? (_: []), emacs ? pkgs.emacs27-nox }:
+{ name, src, deps ? (_: [ ]), emacs ? pkgs.emacs27-nox }:
 
 let
   inherit (pkgs) emacsPackages emacsPackagesGen;
@@ -8,11 +8,13 @@ let
 
   finalEmacs = (emacsPackagesGen emacs).emacsWithPackages deps;
 
-  srcFile = if isString src
+  srcFile =
+    if isString src
     then toFile "${name}.el" src
     else src;
 
-in depot.nix.writeScriptBin name ''
+in
+depot.nix.writeScriptBin name ''
   #!/bin/sh
   ${finalEmacs}/bin/emacs --batch --no-site-file --script ${srcFile} $@
 ''