about summary refs log tree commit diff
path: root/nix/utils/tests/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix/utils/tests/default.nix')
-rw-r--r--nix/utils/tests/default.nix31
1 files changed, 0 insertions, 31 deletions
diff --git a/nix/utils/tests/default.nix b/nix/utils/tests/default.nix
index b87c29cac7..344a1771d7 100644
--- a/nix/utils/tests/default.nix
+++ b/nix/utils/tests/default.nix
@@ -11,7 +11,6 @@ let
 
   inherit (depot.nix.utils)
     isDirectory
-    realPathIsDirectory
     isRegularFile
     isSymlink
     pathType
@@ -34,16 +33,6 @@ let
     (assertUtilsPred "file not isDirectory"
       (isDirectory ./directory/file)
       false)
-    # realPathIsDirectory
-    (assertUtilsPred "directory realPathIsDirectory"
-      (realPathIsDirectory ./directory)
-      true)
-    (assertUtilsPred "symlink to directory realPathIsDirectory"
-      (realPathIsDirectory ./symlink-directory)
-      true)
-    (assertUtilsPred "realPathIsDirectory resolves chained symlinks"
-      (realPathIsDirectory ./symlink-symlink-directory)
-      true)
     # isRegularFile
     (assertUtilsPred "file isRegularFile"
       (isRegularFile ./directory/file)
@@ -76,31 +65,12 @@ let
     # missing files throw
     (assertThrows "isDirectory throws on missing file"
       (isDirectory ./does-not-exist))
-    (assertThrows "realPathIsDirectory throws on missing file"
-      (realPathIsDirectory ./does-not-exist))
     (assertThrows "isRegularFile throws on missing file"
       (isRegularFile ./does-not-exist))
     (assertThrows "isSymlink throws on missing file"
       (isSymlink ./does-not-exist))
   ]);
 
-  symlinkPathTypeTests = it "correctly judges symlinks" [
-    (assertEq "symlinks to directories are detected correcty"
-      ((pathType ./symlink-directory).symlink or null) "directory")
-    (assertEq "symlinks to symlinks to directories are detected correctly"
-      ((pathType ./symlink-symlink-directory).symlink or null) "directory")
-    (assertEq "symlinks to nowhere are not distinguished from files"
-      ((pathType ./missing).symlink or null) "regular-or-missing")
-
-    # These tests are commented out because they no longer work with
-    # restrict-eval turned on.
-
-    # (assertEq "symlinks to files are detected-ish"
-    #   ((pathType ./symlink-file).symlink or null) "regular-or-missing")
-    # (assertEq "symlinks to symlinks to files are detected-ish"
-    #   ((pathType ./symlink-symlink-file).symlink or null) "regular-or-missing")
-  ];
-
   cheddarStorePath =
     builtins.unsafeDiscardStringContext depot.tools.cheddar.outPath;
 
@@ -125,6 +95,5 @@ in
 
 runTestsuite "nix.utils" [
   pathPredicates
-  symlinkPathTypeTests
   storePathNameTests
 ]