about summary refs log tree commit diff
path: root/nix/lazy-deps/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix/lazy-deps/default.nix')
-rw-r--r--nix/lazy-deps/default.nix6
1 files changed, 6 insertions, 0 deletions
diff --git a/nix/lazy-deps/default.nix b/nix/lazy-deps/default.nix
index bfdf5490ce..1b88f66225 100644
--- a/nix/lazy-deps/default.nix
+++ b/nix/lazy-deps/default.nix
@@ -65,6 +65,12 @@ let
         PATH="''${result}/bin:$PATH"
         exec "''${TARGET_TOOL}" "''${@}"
       '';
+
+      # Access this to get a compatible nix-shell
+      passthru.devShell = pkgs.mkShellNoCC {
+        name = "${self.name}-shell";
+        packages = [ self ];
+      };
     }
     ''
       # Write the dispatch code