about summary refs log tree commit diff
path: root/nix/fetchGoModule/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix/fetchGoModule/default.nix')
-rw-r--r--nix/fetchGoModule/default.nix32
1 files changed, 0 insertions, 32 deletions
diff --git a/nix/fetchGoModule/default.nix b/nix/fetchGoModule/default.nix
deleted file mode 100644
index 84794bbc50..0000000000
--- a/nix/fetchGoModule/default.nix
+++ /dev/null
@@ -1,32 +0,0 @@
-{ lib, pkgs, ... }:
-
-let
-
-  inherit (lib)
-    lowerChars
-    replaceStrings
-    upperChars
-  ;
-
-  caseFold = replaceStrings upperChars (map (c: "!" + c) lowerChars);
-
-in
-
-{ path, version, sha256 }:
-
-pkgs.fetchurl {
-  name = "source";
-  url = "https://proxy.golang.org/${caseFold path}/@v/v${version}.zip";
-  inherit sha256;
-
-  recursiveHash = true;
-  downloadToTemp = true;
-
-  postFetch = ''
-    unpackDir="$TMPDIR/unpack"
-    mkdir "$unpackDir"
-
-    ${pkgs.unzip}/bin/unzip "$downloadedFile" -d "$unpackDir"
-    mv "$unpackDir/${path}@v${version}" "$out"
-  '';
-}