about summary refs log tree commit diff
path: root/nix/buildkite/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix/buildkite/default.nix')
-rw-r--r--nix/buildkite/default.nix10
1 files changed, 2 insertions, 8 deletions
diff --git a/nix/buildkite/default.nix b/nix/buildkite/default.nix
index d299d52624..eb8061cf6b 100644
--- a/nix/buildkite/default.nix
+++ b/nix/buildkite/default.nix
@@ -6,7 +6,7 @@
 #
 # The structure of the file that is being created is documented here:
 #   https://buildkite.com/docs/pipelines/defining-steps
-{ pkgs, ... }:
+{ depot, pkgs, ... }:
 
 let
   inherit (builtins)
@@ -29,6 +29,7 @@ let
     unsafeDiscardStringContext;
 
   inherit (pkgs) lib runCommandNoCC writeText;
+  inherit (depot.nix.readTree) mkLabel;
 in
 rec {
   # Creates a Nix expression that yields the target at the specified
@@ -46,13 +47,6 @@ rec {
     in
     if target ? __subtarget then subtargetExpr else targetExpr;
 
-  # Create a pipeline label from the target's tree location.
-  mkLabel = target:
-    let label = concatStringsSep "/" target.__readTree;
-    in if target ? __subtarget
-    then "${label}:${target.__subtarget}"
-    else label;
-
   # Determine whether to skip a target if it has not diverged from the
   # HEAD branch.
   shouldSkip = parentTargetMap: label: drvPath: