about summary refs log tree commit diff
path: root/nix/buildLisp/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix/buildLisp/default.nix')
-rw-r--r--nix/buildLisp/default.nix7
1 files changed, 3 insertions, 4 deletions
diff --git a/nix/buildLisp/default.nix b/nix/buildLisp/default.nix
index 442ac7dfe1..ab23b30210 100644
--- a/nix/buildLisp/default.nix
+++ b/nix/buildLisp/default.nix
@@ -413,10 +413,9 @@ let
         (ext:install-c-compiler)
 
         (c:build-program
-         (make-pathname :name "${name}"
-                        :directory (concatenate 'string
-                                                (getenv-or-fail "out")
-                                                "/bin"))
+         (merge-pathnames (make-pathname :directory '(:relative "bin")
+                                         :name "${name}")
+                          (truename (getenv-or-fail "out")))
          :epilogue-code `(progn
                           ;; UIOP doesn't understand ECL, so we need to make it
                           ;; aware that we are a proper executable, causing it