about summary refs log tree commit diff
path: root/nix/buildGo/external/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix/buildGo/external/default.nix')
-rw-r--r--nix/buildGo/external/default.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/nix/buildGo/external/default.nix b/nix/buildGo/external/default.nix
index de29df4164..6540faf04c 100644
--- a/nix/buildGo/external/default.nix
+++ b/nix/buildGo/external/default.nix
@@ -56,8 +56,8 @@ let
         throw "missing local dependency '${lib.concatStringsSep "." d}' in '${path}'"
       ) self) entry.localDeps;
 
-      foreignDeps = map (d: lib.attrByPath [ d ] (
-        throw "missing foreign dependency '${d}' in '${path}'"
+      foreignDeps = map (d: lib.attrByPath [ d.path ] (
+        throw "missing foreign dependency '${d.path}' in '${path}, imported at ${d.position}'"
       ) depMap) entry.foreignDeps;
 
       args = {