about summary refs log tree commit diff
path: root/nix/buildGo/example/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix/buildGo/example/default.nix')
-rw-r--r--nix/buildGo/example/default.nix13
1 files changed, 3 insertions, 10 deletions
diff --git a/nix/buildGo/example/default.nix b/nix/buildGo/example/default.nix
index 99c0a7d79b..6756bf39e2 100644
--- a/nix/buildGo/example/default.nix
+++ b/nix/buildGo/example/default.nix
@@ -8,7 +8,7 @@
 # users a quick introduction to how to use buildGo.
 
 let
-  buildGo = import ../default.nix {};
+  buildGo = import ../default.nix { };
 
   # Example use of buildGo.package, which creates an importable Go
   # package from the specified source files.
@@ -19,17 +19,11 @@ let
     ];
   };
 
-  # Example use of buildGo.proto, which generates a Go library from a
-  # Protobuf definition file.
-  exampleProto = buildGo.proto {
-    name = "exampleproto";
-    proto = ./thing.proto;
-  };
-
   # Example use of buildGo.program, which builds an executable using
   # the specified name and dependencies (which in turn must have been
   # created via buildGo.package etc.)
-in buildGo.program {
+in
+buildGo.program {
   name = "example";
 
   srcs = [
@@ -38,7 +32,6 @@ in buildGo.program {
 
   deps = [
     examplePackage
-    exampleProto
   ];
 
   x_defs = {