about summary refs log tree commit diff
path: root/nix/bufCheck/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix/bufCheck/default.nix')
-rw-r--r--nix/bufCheck/default.nix9
1 files changed, 9 insertions, 0 deletions
diff --git a/nix/bufCheck/default.nix b/nix/bufCheck/default.nix
new file mode 100644
index 0000000000..6d17cb460e
--- /dev/null
+++ b/nix/bufCheck/default.nix
@@ -0,0 +1,9 @@
+# Check protobuf syntax and breaking.
+#
+{ depot, pkgs, ... }:
+
+pkgs.writeShellScriptBin "ci-buf-check" ''
+  ${depot.third_party.bufbuild}/bin/buf check lint --input "${depot.depotPath}"
+  # Report-only
+  ${depot.third_party.bufbuild}/bin/buf check breaking --input "${depot.depotPath}" --against-input "${depot.depotPath}/.git#branch=canon" || true
+''