about summary refs log tree commit diff
path: root/home/modules/alacritty.nix
diff options
context:
space:
mode:
Diffstat (limited to 'home/modules/alacritty.nix')
-rw-r--r--home/modules/alacritty.nix46
1 files changed, 46 insertions, 0 deletions
diff --git a/home/modules/alacritty.nix b/home/modules/alacritty.nix
new file mode 100644
index 0000000000..ba26360fe9
--- /dev/null
+++ b/home/modules/alacritty.nix
@@ -0,0 +1,46 @@
+{ config, lib, pkgs, ... }:
+{
+  home.packages = with pkgs; [
+    alacritty 
+  ];
+
+  programs.alacritty = {
+    enable = true;
+    settings = {
+      font.size = 6;
+
+      colors = with import ../common/solarized.nix; rec {
+        # Default colors
+        primary = {
+          background = base3;
+          foreground = base00;
+        };
+
+        cursor = {
+          text = base3;
+          cursor = base00;
+        };
+
+        # Normal colors
+        normal = {
+          inherit red green yellow blue magenta cyan;
+          black = base02;
+          white = base2;
+        };
+
+        # Bright colors
+        bright = normal;
+        # bright = {
+        #   black = base03;
+        #   red = orange;
+        #   green = base01;
+        #   yellow = base00;
+        #   blue = base0;
+        #   magenta = violet;
+        #   cyan = base1;
+        #   white = base3;
+        # };
+      };
+    };
+  };
+}