about summary refs log tree commit diff
path: root/fun/idual/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'fun/idual/default.nix')
-rw-r--r--fun/idual/default.nix19
1 files changed, 19 insertions, 0 deletions
diff --git a/fun/idual/default.nix b/fun/idual/default.nix
new file mode 100644
index 0000000000..e051f1c812
--- /dev/null
+++ b/fun/idual/default.nix
@@ -0,0 +1,19 @@
+{ pkgs, lib, ... }:
+
+let
+  inherit (pkgs) python python3 python3Packages;
+
+  opts = {
+    pname   = "idualctl";
+    version = "0.1";
+    src     = ./.;
+
+    propagatedBuildInputs = [
+      python.broadlink
+    ];
+  };
+in lib.fix (self: {
+  package = python3Packages.buildPythonPackage opts;
+  script  = python3Packages.buildPythonApplication opts;
+  python  = python3.withPackages (_: [ self.package ]);
+})