about summary refs log tree commit diff
path: root/fun/idual/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'fun/idual/default.nix')
-rw-r--r--fun/idual/default.nix11
1 files changed, 6 insertions, 5 deletions
diff --git a/fun/idual/default.nix b/fun/idual/default.nix
index 0f87f4ae1a..1acf287bfb 100644
--- a/fun/idual/default.nix
+++ b/fun/idual/default.nix
@@ -4,19 +4,20 @@ let
   inherit (pkgs) python3 python3Packages;
 
   opts = {
-    pname   = "idualctl";
+    pname = "idualctl";
     version = "0.1";
-    src     = ./.;
+    src = ./.;
 
     propagatedBuildInputs = [
       depot.third_party.python.broadlink
     ];
   };
   package = python3Packages.buildPythonPackage opts;
-  script  = python3Packages.buildPythonApplication opts;
-in depot.nix.readTree.drvTargets {
+  script = python3Packages.buildPythonApplication opts;
+in
+depot.nix.readTree.drvTargets {
   inherit script;
-  python  = python3.withPackages (_: [ package ]);
+  python = python3.withPackages (_: [ package ]);
   setAlarm = pkgs.writeShellScriptBin "set-alarm" ''
     echo "setting an alarm for ''${1}"
     ${pkgs.systemd}/bin/systemd-run --user --on-calendar="''${1} Europe/London" --unit=light-alarm.service